Wayland with Nvidia

Hi there, I have not tried fedora yet. I want to ask , if I switch displaty server from x11 to wayland, will nvidia drivers work anymore ? I heard that fedora team is bringing working wayland sessions with nvidia drivers in upcoming fedora 36 . Is this true ?

1 Like

Yes, it is true. I am currently using Fedora 36 on Wayland with the NVIDIA drivers.

wow i cant believe fedora team make that possible. can you please show me screenshot of about and nvidia powermize settings.

It’s not perfect either. In my case, both Zoom Meetings and Discord don’t work in a Wayland session. Those are not new bugs or specific to Fedora. It seems to be issues with Wayland sessions and some Electron apps (VSCode and Slack work fine, for example)

There are limitations.

It works but nvidia-settings is not compatible so you dont have as much / any driver controls.

It also depends on which Nvidia card you have. I have an old one and Nvidia dropped support for it in the newer drivers. So I am stuck with the 470 drivers and that was before Nvidia fixed some of the Wayland problems.

Correct.
Any nvidia card that requires the 470 driver or earlier will not work with wayland at all. Only the 495 and newer drivers work with wayland.

[original question deleted - have made most of it redundant with a bit of research].

I’m going to follow the instructions at Howto/NVIDIA - RPM Fusion for installing the kmod-nvidia package, and getting it working for my GTX 1050 Ti Mobile (with Secure Boot enabled) on Fedora 36 (w/ Gnome on Wayland).

I’m going to do a system backup first, but are there any other caveats I should be aware of before attempting this?

My only suggestion is that you follow the instructions exactly, and that means for 99+% of users that you install akmod-nvidia and not kmod-nvidia. All the other necessary packages should be pulled in as dependencies automatically.

The xorg-x11-drv-nvidia-cuda package is not automatically installed and is not needed unless your apps require cuda. It may be necessary to install that one as well.

Thanks. That all worked nicely. Even signing the driver and handing the public key to the firmware is nicely streamlined. I was half-expecting a nightmare.