Weird Brightness Issues

I’m observing weird issues with my display brightness

  1. Adjusting the display via a dedicated keyboard shortcut causes repetitive increase/decrease according to my last choice and continues till the logout.

  2. Whenever I plug my charger after a few moments the brightness drops to 2% and it happens again when I plug out my charger.

My Laptop Details
MSI Modern 15 Ryzen 5 5500U Variant
https://www.smartprix.com/laptops/msi-modern-15-a5m-065in-laptop-ryzen-5-8gb-ppd1kevk4xei

Hi,

  1. I want to clarify, are you using fn key or creating custom shortcut?

    If you could change the brightness with GUI slider and the brightness changes smoothly, it could be your acpi driver (if using fn) and it could be the package (for example brightnessctl) if you’re using custom keyboard shortcut for controlling the brightness.

  2. In my laptop, look like my system save 2 values of brightness. First the value when the power plug in and the value when power unplug. Maybe you can test it by make the value for unplugged power to 50% and the plugged power to 75% the system can remember or not. Just test it again on my Fedora Workstation and it’s now only save one/same value. I don’t know since when (or maybe those from different distros).

    Btw, sometimes when unplug the power, the system can’t remember the last value and brightness back to 0.

Your explanation is making good sense to me. Thanks!

Yes, the Fn key is being used.

Now I’m on F34 KDE just landed there before being on the Gnome (Workstation). But previously I’ve been in the F35 KDE. In all these, I’ve faced the above two mentioned problems.

Help me out.

Hi, I’m just thinking, maybe you want first to check with libinput response.

First I suggest to unplug your mouse then on terminal run sudo libinput debug-events then press fn + brightnessUp/Down, check if there any repetitive input reported on terminal:

$ sudo libinput debug-events
....
 event8   KEYBOARD_KEY            +3.763s	KEY_BRIGHTNESSUP (225) pressed
 event8   KEYBOARD_KEY            +3.763s	KEY_BRIGHTNESSUP (225) released
 event8   KEYBOARD_KEY            +5.937s	KEY_BRIGHTNESSDOWN (224) pressed
 event8   KEYBOARD_KEY            +5.937s	KEY_BRIGHTNESSDOWN (224) released
....

Make sure only 2 events for each keyboard press (pressed and released).

Then you could also check with Gnome Settings > Accessibility > Typing then click Repeat keys . You could try to disable it or adjust the delay and speed.

The last one if above not working, here the documentation about acpi_backlight parameters. You could add the parameter with grubby command and reboot to take effect.

# Example of adding parameters (please refer to doc link above).
sudo grubby --args="acpi_backlight=vendor" --update-kernel=ALL

# Example of removing the parameters
sudo grubby --remove-args="acpi_backlight=vendor" --update-kernel=ALL
1 Like