Weird line spacing using gnome terminal on fedora 34

The line spacing setting in current profile of gnome terminal is default value 1.0. Everything, include powerline symbols, is rendered well before. But recently, the powerline symbols’ rendering is broken as below.


The line spacing is increased, but the gnome terminal setting is still 1.0.
Anyone knows the reason?

EDIT: compare weird gnome-terminal with normal kitty:

2 Likes

Could you also add an image of the “normal” line spacing so folks can compare the two?

You should report it upstream similar to the following:

Sorry about that. The compared screenshot is attached.

1 Like

Ah, yes, that makes it nice and clear.

I’m on F34 too here, with gnome-terminal-3.40.1-1.fc34.x86_64. I see that changing the “height” value here in profile preferences increases the height of each line, and thus fewer lines fit:

The only other thing I can think of is to check gnome-tweak-tools, because any changes to fonts made there are also picked up by gnome-terminal (and all other Gnome applications).

Also, and we should double-check this, but the guifont etc. options that you are using in your vimrc are only used in Gvim as far as I know. In a terminal, vim just picks up whatever font settings the terminal uses.

There is no gvim in my post. The right hand of the screenshot is Vim under Kitty terminal. My terminal Height setting is 1.0. But still, gnome-terminal performs as left hand of the screenshot. I have been searching around for few days and it seems that libpango or libvte is the key, as Weird line spacing using gnome terminal on fedora 34 - #3 by vgaetera shows.

OK, so where are you setting the fonts for use by vim in the terminal then?

That’s a link to their reply above. I don’t see any issues specifically about this.

I’m not seeing the issue here, so it’s hard to debug at the moment:

Here it is in a tmux session too:

My gnome-terminal font is system mono font set by gnome-tweak-tool, Source Code Pro Medium.

In the link, they discussed as below:

Setting the system language to zh_CN will trigger the issue. They think it’s the line height, decided by CJK fonts, is higher than before and makes powerline symbol render broken.

Then I tried on my laptop. When switch system language to English, gnome-terminal do render better. The line height changes to normal appearance, but still have some defects, especially the powerline symbols. So I’m using English UI and gnome-terminal is much better now.

1 Like