What -- is the deal with reboots on Discover updates?

/seinfeld mode

I’m a pretty recent convert to Fedora from Debian on a laptop (desktops still mainly using Debian). In the past 4 or 5 days Discover has updated system bits about 4 or 5 times (I’ve lost count; I think it’s 5) and each time I’ve had to reboot the system. Why? For years I’ve been dinging Windows for requiring a restart almost every time it updates something. Fedora is just as bad! On the other hand, Debian hardly ever requires a restart which always impressed me.

So, what’s up with reboots? Have I just arrived at Fedora at a bad time - I’m running Fedora 37? Is it because Fedora is not a LTS distro? Or is this the way it is? TBH I’m not very impressed with this aspect but I’m going to stick with Fedora - it’s generally providing a good experience on my i7-12700 Dell laptop (even though the Nvidia driver is still being kicked out for reasons I know not).

Thanks for any input. Remember: I’m a relative Fedora noob (I used it in VMs on the desktop previously) and I maybe asking a FAQ.

Requiring reboots to update system packages is intended behaviour for Gnome Software/Discover. Please see these posts for more discussion on this:

and this one too:

The solution here suggests that Discover has (or will have) an option to do “on the fly” updates.

1 Like

I’m using KDE on Debian (11) and Fedora. Discover is the standard method of automatically updating system bits on both distros. Unless the kernel or a driver is updated - requiring initrd/initramfs to be rebuilt - then there shouldn’t need to be a reboot. I’ve been using Debian for years, requiring very infrequent reboots, and the system remains rock-solid. Thanks for the links (I google for the answers first and if I don’t find anything satisfactory, usually on the first page I have to say, then I ask the forum).

If I’ve gleaned the info correctly, rebooting on updates is a policy decision somewhere (where?)? Is that correct?

I won’t go into this again, but as discussed in the threads I’ve posted, it’s not quite as simple as this. “Nothing happens” does not mean “nothing can happen”. As Matthew explained in one thread—updating a live system is like modifying components of a car while its running. It could keep running, but it could also break badly.

For gnome software, this was made by the gnome development community. For Discover, it’ll be the KDE folks.

One can just use

dnf update

if they want to run updates on a live system. Neither Discover nor Gnome software prevents one from using dnf.

I don’t know how Debian does it—perhaps they have a downstream change to Discover to use on the fly updates by default. No idea, and not a clue where to look for this info.

I found this behavior bothersome as well, so I configured GNOME Software to never apply updates on its own.

1 Like

Please start a new thread for this issue and we may be able to assist.

I did the same, and have never had an issue. I use a cron job with dnf for my updates and seldom need an actual reboot except for kernel or driver updates.

1 Like

Apparently you’re courting disaster by not rebooting!

It’s the same issue I was communicating with you about about two weeks ago. I just gave up. The laptop works very well with the i7-12700 iGPU. I left a vestigial Windows 11 on the machine which I can boot into if I need to use the 3050. Linux and Nvidia drivers seems to be unsolvable.

If so then it has worked for 12 years with no problems. :innocent:

1 Like

Since Fedora is more on the cutting edge it will have a lot more updates than Debian as well as Red Hat.As others have stated and I as well turn off auto updates and also use dnf upgrade.One suggestion would be set a time maybe once a week to update and rebooting once a week if needed isn’t a bad idea anyway.

1 Like

Can you open a new issue about this please (or link to one you’ve opened)?

In general, using the RPM Fusion Nvidia drivers seems to work for most:

https://rpmfusion.org/Howto/NVIDIA

I’m going to close this thread now. There’s no problem here to solve.