When I turn off the Wifi energy saving option, it turns off the Wifi. Is that a bug?

I put a torrent to download and left the computer on all night. In the morning, when I went to see what had already been downloaded, the computer had Wifi turned off. I had to go to the Wifi settings and turn it on manually. I found this strange and went to the power settings. In the energy saving part, it had an option “Wifi can be turned off to save energy” which was on. I turned off this option because I don’t want the computer to be turning off Wifi alone. The problem is that when I do this the system simply turns off my Wifi immediately. I think this would be a bug. This was not supposed to happen. I just didn’t want the system to turn off Wifi to save battery, I didn’t want it to turn off Wifi. When I turn on Wifi manually, it automatically enables this power option again. Is this really a bug? Does any of you have the same problem?

I would suspect that it is related to being a laptop and automatic energy saving features. If it is running on the external power you can turn off that feature and it should fix it. The button you referred to is for manually turning off the wifi.
My laptop has additional buttons on the control panel for power. At the bottom is an “automatic suspend” button that can be used to set the delay on suspend when plugged in for both battery and plugged in. Mine is set to “When on battery power” and under that you find the settings for both battery and plugged in. If the plugged in feature is off then it does not suspend or activate other automatic power saving features while plugged in afaik. At least I have no problems that way.

My laptop is an Acer Aspire M5:
https://www.notebookcheck.info/Acer-Aspire-M5-481PT-6644.90048.0.html
It has only a shortcut to turn Wifi on and off (Fn + F3).
Here is a picture of the option I’m talking about:

As I said above, the button to turn off the wifi is to do that manually. Leave it on.

This image is the bottom part of the power control panel on mine.


If I click on the “Automatic Suspend” line where it says “When on battery power” it brings up the following. (On yours – the “Suspensao automatica” line)
Screenshot from 2020-05-30 15-20-51

Note that “Plugged In” is turned off.
That disables all automatic power suspensions when the device is plugged in and should prevent the laptop from going to suspension during long term events as you described in your problem.

If “Plugged In” is turned on then the laptop will automatically suspend with the selected delay.

Your problem is not a bug, it seems to be a misconfiguration for what you are doing.

Adding to what @computersavvy said, you can view the NetworkManager event logs from journalctl. Normally, the logs are too large to fpaste, but if you output them to a file and attach them somewhere (like a Dropbox account or Google Drive with share links), we could review.

  1. Try to upload them to fpaste:
    $ sudo journalctl -b | fpaste

  2. Or output them to a file:
    $ sudo journalctl -b > /tmp/journalctl.out