Which services to disable on fedora 34 for home use

Hello, everyone!

I am using Fedora 34 for home purposes. I am a web developer and therefore use docker and sometimes not so common software.

Nonetheless, I believe there is a fair amount of services I could disable to make my machine boot and (specially) shutdown quicker.

This is the result of systemd-analyze critical-chain:

graphical.target @17.868s
└─multi-user.target @17.868s
 └─plymouth-quit-wait.service @14.043s +3.824s
   └─systemd-user-sessions.service @14.031s +6ms
     └─remote-fs.target @14.028s
       └─remote-fs-pre.target @14.027s
         └─nfs-client.target @4.502s
           └─gssproxy.service @4.493s +9ms
             └─network.target @4.489s
               └─wpa_supplicant.service @5.299s +5ms
                 └─dbus-broker.service @4.008s +53ms
                   └─dbus.socket @3.976s
                     └─sysinit.target @3.972s
                       └─systemd-userdbd.service @14.097s +19ms
                         └─systemd-userdbd.socket @873ms
                           └─system.slice
                             └─-.slice

Is there a tool that can do that for me?

If not, which services can I disable?

Regards

1 Like

It looks like most of the time is spent mounting an nfs share. Do you have an nfs share in your /etc/fstab? If so, try converting it to a systemd-automount.

1 Like

I am not sure what you can gain there. The total boot time shown is only 17.868 seconds.

It looks like 10 seconds of that is from the NFS mount.

If that is an SSD, 14 seconds is pretty slow.

Do nothing as 1.2 GB of memory for default installation is fine … maybe just switch to NVMe drive for speed gain …

How bad an idea is to disable playmouth-quit-wait-service? Because it this only service which is taking the longest time from what I can see in my critical-chain.

└─plymouth-quit-wait.service @6.232s +4.599s

Plymouth runtime is a simple service that gives a nice boot screen, you can disable it entirely giving console boot messages but boot time is (nearly) identical. I have a desktop with two SSD and one NVMe M2 drives. EFI and Boot partions are on one SSD, the rest in single logical partition and boot time is really fast. With everything in NVMe you no longer access BIOS … playing around about boot time isn’t significant, processor, memory and storage performance needs to be tweaked together, operating system run times just waiting in the background don’t significantly impact performance.

I don’t think we can disable playmouth runtime. I tried. And reboot to see my system-critical chain. But it was sitting there in red color like it was sitting before. Instead of decreasing the boot time, instead, it increased my boot time by 1 second. Weird.

Before Vs After

I used this command: sudo systemctl disable plymouth-quit-wait.service
Maybe, I need to completely mask it from running.

Are you sure you are reading the output correctly? I don’t think that means that plymouth-quit-wait.service is adding 4 seconds to your boot time.

You might be right. Maybe Plymouth has nothing to do with the slow down.

Those lines were in red color which has a plus sign with extra seconds, so I thought that maybe they are the reason for the slowdown.

I am not sure what the right way is but I usually compare the difference between the @ times.

1 Like

Time permitting it may be easier to start with the everything iso and roll your own.

You’re a web developer using containers and specific apps … aren’t you confusing Fedora, a simple operating system, with latency connecting and disconnecting from your virtual workspace? To accelerate boot, shutdown time use hardware tweaks like suspend function or non volatile memory (NVMe), to see unused processes in the background use gnome-system-monitor or other GUI/CLI tools …