Why does pcscd draw so much power when not in use?

The highest power draw listed by tlp on this Dell E7250 at idle is the process pcscd which is for smart card readers. This laptop has a smart card reader, but I do not use it.

Is there a power saving option to avoid this? Or in the worst case, an option to disable the device?

From the devices tab in tlp the Broadcom 5880 USB device is constantly drawing power:

lsusb identifies it also:

Bus 001 Device 005: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor

From searching online it indeed corresponds to a smart card reader.

If you don’t use it you can disable it:

systemctl disable pcscd.service
systemctl stop pcscd.service

2 Likes

If you don’t need the BCM5880 chip at all, you could try disabling it in the BIOS setup.

Does the hardware even function properly? What I see here doesn’t look good…

2 Likes

I don’t have a smart card to test the reader, but the status and progress don’t look good at all: https://gitlab.freedesktop.org/libfprint/libfprint/-/issues/38

I did not find any setting mentioning the smart card reader in BIOS. Any idea what it might be called?

I disabled and stopped pcscd.service but there is a message:

Warning: Stopping pcscd.service, but it can still be activated by:
pcscd.socket

Indeed, it restarted automatically, so I also disabled and stopped the socket:

systemctl disable pcscd.socket
systemctl stop pcscd.socket
systemctl disable pcscd.service
systemctl stop pcscd.service

Now pcscd and BCM5880 no longer show up in powertop's list. I hope the hardware isn’t still drawing power needlessly.

2 Likes