Why don't I see Windows boot option after installing Fedora 33?

Here is my partition right now:

I have gone through similar questions including below:

Output of sudo efibootmgr:

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0005,0003
Boot0000* Fedora
Boot0001* Fedora
Boot0003* Hard Drive
Boot0005* UEFI OS

Output of sudo lsblk | fpaste: https://paste.centos.org/view/f7d67a35

There is a solution at After install of F32 from USB - can't boot UEFI Windows 10, but I’m not sure if it is relevant to me.

Please help me.

Did you maybe overwrite the content of the /boot/efi partition in which the Windows bootloader was? (In the installer, there is a check box where you can select ‘Format’ (or not to)).

1 Like

Hi @florian, let me explain one by one.

  • sda1,2,3 these drives were automatically created when installing windows.
  • when installing Fedora
    • I remove everything else which was left in the hard drive.
    • proceeded with automatic partitioning which created sda5,6

I have not touched /boot/efi when installing Fedora.

What can I do at this point?

I’m in a similar position. Reinstalling Fedora 33 with an existing Windows 10 installation.
In my case, Fedora is on a different physical drive than Windows. Both Windows and Fedora are EFI

Start: Windows HD unplugged.
Install Fedora
Update and check Fedora
Shutdown machine and plug in Windows HD
Restart machine, check BIOS to see that UEFI “sees” Fedora and Windows. Yes.
Restart machine, boot to Fedora. Windows doesn’t show up in the Fedora boot options.
Login to Fedora. Become root (or use sudo).
Navigate to location of grub.cfg (/boot/efi/EFI/fedora)
cp grub.cfg to grub.cfg.old
run ‘grub2-mkconfig > grub.cfg’ in /boot/efi/EFI/fedora
Watch output from this command. something like:
Found Windows Boot Manager on /dev/sda5@/efi/Microsoft/Boot/bootmgfw.efi
(Note: In this case Fedora is on /dev/sdb{x}, Windows on /dev/sda{x}, and sda5 is where the Windows EFI partition is).
Logout
Reboot machine
Windows menu entry should appear.

1 Like