Why grub render a underscore before i'm able to select a kernel to start?

I don’t know if this is normal now but since some update, when start my laptop a underscore have to pass over all the lines betwen the boot options and the lines of the bottom of the screen, I’ll attach a video, sorry for the out of focus but at least you can se the underscore moving on the screen.

Grub Fedora 33

Laptop info:
Dell 5575

System info:
Operating System: Fedora 33
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.12.14-200.fc33.x86_64
OS Type: 64-bit
Processors: 8 × AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
Memory: 15.3 GiB of RAM
Graphics Processor: AMD RAVEN

The same for me, but after some kernel updates it disappears and later reappears. I’m not sure but I suspect it’s related to the graphics driver, but i am not able to find solution. Also in my case there is often situation when notebook stuck and not boot after grub.

After adding some params to kernel cmd line and grub2-mkconfig underscore cursor rendering disappeared

thanks for the feedback, so i’ll wait and see if some update remove this, many thanks.

It would be nice if you posted exactly what changes you made to the kernel command line so that others may be able to find a fix as well. Also it appears that a bug report with the fixes you found could help the maintainers in fixing the bug as well.

I can, but I believe it’s not important. I have problems with my notebook display, it’s detected as PSR2 panel and flickering. So in my setup, there is i915 param (i915.enable_psr=0) to disable PSR. Because there were some changes in PSR in the 5.13.4 kernel version, I tried to enable PSR and check if works or not. Was not working, so i revert it.

Old:
GRUB_CMDLINE_LINUX="rhgb quiet nmi_watchdog=0 i8042.dumbkbd=1 i915.enable_psr=0"

New:
GRUB_CMDLINE_LINUX="rhgb quiet nmi_watchdog=0 i8042.dumbkbd=1 i915.enable_psr=1"

I have encountered the same problem on an AMD machine (Thinkpad T495) and I am sure it is not related to kernel, as the kernel isn’t even loaded at that stage, right?

What currently works for me is setting the “UEFI/Legacy Boot” option in the BIOS to “Both” and “CSM Support” to “Yes”. So it might be an issue with the system firmware.

I agree, I just wanted to say after edit

/etc/default/grub

and regenerate grub file via

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

in my case underscore rendering disappeared.

1 Like

So obviously, if the change in the kernel command line affects the flickering, it does take place before the kernel fully loads. It is , after all, passed to the kernel by grub as parameters that affect the kernel and how the video driver is configured when loaded. The video driver gets loaded by the kernel.

It seems to me that it is directly related to the performance of the video on your system and directly affects the loading of the kernel.

Thank you for posting that so others may see it.

Also, Thank You for adding the reminder that:
After changing the kernel command line in /etc/default/grub, the final step involves running grub2-mkconfig before the change takes effect on the next boot.