WiFi and bluetooth problem - HP Laptop

Hi, can anybody please help me with this issue that i’m actually having?
I don’t have Bluetooth or WiFi connection,
Here is some details of my Laptop HP,

Machine: Type: Laptop System: HP product: HP Laptop 14-ck0xxx v: Type1ProductConfigId
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: 4000 bus ID: 01:00.0 chip ID: 10ec:8168
IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: --------
Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter vendor: Hewlett-Packard driver: N/A port: 3000 bus ID: 02:00.0
chip ID: 10ec:d723
Device-3: Realtek 802.11n WLAN Adapter type: USB driver: btusb bus ID: 1-8:4 chip ID: 0bda:b009
serial: 00e04c000001

[valcorta@localhost ~]$ uname -r
5.0.9-301.fc30.x86_64

Much appreciated,
Thank you!

Victor

Is secureboot disabled in your BIOS or UEFI? Have a HP-Notebook here, when I enable secureboot the wireless connection is gone, when I disable secureboot again the connection is restored.

Welcome to Ask Fedora! Check out #start-here to learn your way around the forum.

Unfortunately, Linux doesn’t include a WiFi driver for your device. You’ll need to disable secure boot and then install one of these two drivers:

In either case, you should be able to install the dependencies for building via sudo dnf install make gcc kernel-headers kernel-devel dkms.

3 Likes

If you’re using an out-of-tree kernel driver, then it won’t be loaded when Secure Boot is enabled, as that requires all kernel modules to be signed.

3 Likes

Well… I forget to mention that i had a double system in my pc, and i tried to disable the Secure boot and the boot manager instantly crashed, so now i’m not able to login in my fedora,
Anyway as i didn’t have anything important there, i will reinstall fedora and clean the other system, and i will try again this what you mention

It’s a bit strange, because from my personal experience you can enable and disable secure boot without such an effect. Are you sure you haven’t disabled UEFI boot instead of just disabling Secure boot?

Disabling UEFI boot indeed will make you unable to boot either Fedora or windows (if that’s your second system) or grub (the boot manager) indeed.

Definitely it is…, but yes I’ve just disabled the Secure boot, i was just able to boot through Windows (yes it was the second one),

Now i’m reinstalling and updating everything, i also disabled the Secure boot beforehand do something, and the system looks ok now, just left wait for that and then try to install those eternal drivers

1 Like

Guys, thank you so much for your help, info and knowledge shared with me :),

I could solve the problem that i was having following exactly this steps in the repo that refi64 shared, precisely the one for my specifical card, https://github.com/smlinux/rtl8723de

I’ve been working with a workmate here and we are so glad for your help,

Thank you again,
Cheers!

3 Likes

This post was flagged by the community and is temporarily hidden.