Wifi connected, IP address assigned but no internet

I am building a minimal Fedora installation for virtualization purposes and hence I picked the custom Fedora Server installation option without the standard package group. On it, I installed NetworkManager-wifi, NetworkManager-tui and iwl7260-firmware (as my device has an AX200 card) and rebooted.

I can connect to an access point - no problem - but I cannot connect to the internet using WiFi. What else do I need to install or configure to fix this without having to install the entirety of the standard package group? Any help is appreciated.

1 Like

Check the output:

tracepath -4nm5 8.8.8.8
tracepath -6nm5 2001:4860:4860::8888
nslookup ask.fedoraproject.org 8.8.8.8
nslookup ask.fedoraproject.org 2001:4860:4860::8888
1 Like

Thanks, @vgaetera but I had it figured out. As a default configuration, the Fedora Server installation picks 192.168.0.1 (or whatever is the router’s IP address as the default DNS) instead of something that would let you connect with the internet. Here is a screenshot from the installer.

EDIT : Removed the screenshot due to privacy concerns.

After the installation was completed, I installed the aforementioned three packages first and then configured using nmtui for the device to actually have a custom static IP address, set the gateway to the router’s IP address and the DNS to 8.8.8.8. Then I restarted the device and it started working just fine.

EDIT : Removed the screenshot due to privacy concerns.

In the hindsight, it looks like an obvious choice as the installer dumps packages from the local media and hence, would not want to decide on behalf of the user what the DNS should be. :wink:

The client uses the resolvers advertised by the router as it should.
Unfortunately some local ISP/router resolvers don’t work reliably enough.
A common workaround is to use a custom public DNS provider, optionally with DoT.

1 Like

I believe that’s what must have happened. The provider here is not very reliable and hence the gateway was advertised as DNS even when the router was properly configured to stick to 8.8.8.8 for resolving addresses.

For folks who might come across the issue in future, it would be noticed that even when DHCP just works and an address is assigned to the device - the DNS might need manual configuration as it did in my case.

2 Likes