Wifi is wierd in connecting to my network

Hello
I have one Router with 2 different wifi signals. One in 2.4 GHz and one in 5 GHz. They have both the same ssid. Unfortunatly most of the time my wifi usb adapter is connecting to the 2.4 GHz Network. This is okay for getting the most things done, but it is slow in downloading data. How can i change this behaviour on my PC without changing my router settings?

Information from lsusb:

Bus 010 Device 006: ID 057c:8503 AVM GmbH FRITZ!WLAN AC 860

Output of iwconfig (2.4GHz):

wlp5s0u4 IEEE 802.11 ESSID:“o2-WLAN34”
Mode:Managed Frequency:2.447 GHz Access Point: 60:31:97:50:AA:77
Bit Rate=130 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=47/70 Signal level=-63 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:647 Missed beacon:0

iwconfig on 5 GHz:

wlp5s0u4 IEEE 802.11 ESSID:“o2-WLAN34”
Mode:Managed Frequency:5.2 GHz Access Point: 60:31:97:50:AA:78
Bit Rate=300 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=38/70 Signal level=-72 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:47 Missed beacon:0

Here is a picture of my router Settings:

Have you tried:

sudo iwconfig wlp5s0u4 freq 5.2G

You could also specify the band in network manager by editing the connection. (if you’re running that)

1 Like

I see so there is no problem that it now only uses 5.2GHz and not the 5.18 up to 5.7 GHz? It works for now and i hope it will be in the future.

1.
you should try to change for 2.4 GHz the “WLAN-Modus” to g/n only IF you don’t have any device which needs b.
/b retards higher speed

2.
switch ON “Funkkanal Auto inklusive Kanäle 12/13” IF your device are able to connect to this channels.
I guess OFF is the default config for your and my router and I guess it’s the default config of all/most WLAN routers.
Same goes for “Funkkanal” to “Auto” esp. regarding default config !

that in mind:
if all other WLAN routers in your area runs WITHOUT channels 12 and 13 this is YOUR mostly FREE channel. This could be an advantage; sort-of…
Cause “Funkkanal” is set default to “Auto” and channel 12/13 is OFF in your neigbours WLAN routers by default they (hopefully) move (all) away from your channel 13 after some time, BECAUSE of THEIR defaults: that are channel 1 to 11 and auto configured (=> distance to the next ~ 5 channels)
Which in turn means: your are mostly ALONE at channel 13 (at some circumstances ) if they are nailed at channels 1 to 8 !

3.
you should try to change for 5 GHz to channels higher than 100 (included).
channels greater than 100 have 1000 mW transmission power (channels < 100 and 2.4 GHz have 200 mW only)
This is the case for german “Fritzbox” and I guess it is standard on other WLAN routers too.
keep in mind channels > 100 are used for RADAR too which sometimes causes long (10 Minutes) config/switching time.

4.
if all your devices are able to run 5GHz WLAN switch OFF 2.4 GHz and free some channels for your neighbours !
I got 40-50 routers in WLAN 2.4 and < 3 in WLAN 5 GHz here !!!

1 Like

I’d like to add that when I need both 2.4Ghz and 5Ghz networks, I personally find it far easier to give them slightly different SSIDs, i.e. something like o2-WLAN34-2 and o2-WLAN34-5. This way I can clearly see which one my device is connected to or choose the one I want.

2 Likes

I would strongly suggest using different SSIDs, too.

There is no setting for WiFi Mode G/N in the webinterface.

How can i setup my wifistick to connect to channels over 100?

Can i do something according like

sudo iwconfig wlp5s0u4 freq 100-140?

This is the output of iwlist:

wlp5s0u4 32 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 12 : 2.467 GHz
Channel 13 : 2.472 GHz
Channel 36 : 5.18 GHz
Channel 40 : 5.2 GHz
Channel 44 : 5.22 GHz
Channel 48 : 5.24 GHz
Channel 52 : 5.26 GHz
Channel 56 : 5.28 GHz
Channel 60 : 5.3 GHz
Channel 64 : 5.32 GHz
Channel 100 : 5.5 GHz
Channel 104 : 5.52 GHz
Channel 108 : 5.54 GHz
Channel 112 : 5.56 GHz
Channel 116 : 5.58 GHz
Channel 120 : 5.6 GHz
Channel 124 : 5.62 GHz
Channel 128 : 5.64 GHz
Channel 132 : 5.66 GHz
Channel 136 : 5.68 GHz
Channel 140 : 5.7 GHz
Current Frequency:5.2 GHz (Channel 40)

I dont want to set a new ssid because i would have to reconfigure alot of devices and my flatmates, too.

That’s totally understandable, but changing at least one of two SSID’s name now can save you a lot of trouble later )))

You can change SSID which is used by fewer of devices. And you can change only name of SSID, they can still both have the same password (though changing just the name will likely require to reenter the password on most mobile devices).

you need to set channel 100 in your WLAN-Router !

hint to different SSID’s:
some router able to do “bandsteering” (I hope it’s the right word !?) which needs on both WLAN’s (2.4, 5) the same SSID.
I don’t know if your router is able to that !

what bandsteering does:
it automatically moves you device from one band to another according to what is better to reach or what provides better speed. a sort of roaming…

1 Like

Alright found it :slight_smile:
I think my router is able to do this bandsteering thingy. I set it to channel 100. and its working. But it does show me a bitrate of just 260 Mb/s compared to the 300Mb/s on channel 40.

but it looks right for me, we have 50k in the contract:

okay, maybe your are better up with your channel 40, but connection speed varies over time.
you need to measure it, maybe, over a longer download [1] AND if you got mobile devices from a longer distance too.

General:
high frequency less distance and vice versa
=> 5 GHz-Wlan for high rate on low distances and 2.4 for low(er) rate on higher distances.
with a slight exception: 1000 mW transmission power against 200 mW makes a diff.

the main feature for channel > 100 are higher transmission power and these channels are mostly un-used.
But choosing the right channel highly depends on your local WLAN area/neighbours [2].
I got ~40 neigbours in 2.4 WLAN and only ~5 in 5 GHz here.
but as I said before channel > 11 and > 100 are mostly un-used, because of their router default settings !

[1]
try to downlad a DVD or a parts of it (500 or 1000 MB)
ubuntu has download server that are, according download speed, NOT limited.
you should see max ~5.8 MBytes/s (Bytes !!!, measured via 1 GBit-LAN) according to your 50 Mbit provider rate.

[2]
maybe playstore => AVM WLAN …


to see what’s up in your WLAN neighborhood.

Hint:
sometimes it makes sense to choose exactly the same channel what is used from your strongest seen neighbor !
somehow wave peaks and wave trough ~got added~ in the worsted case maybe to ZERO (means: destroyed) if a wave peaks is overlayed with an wave trough (both waves with same high according to amount).
in the 4. picture from the app the parables should never cross each other => lower signal strength => destroy transmission

1 Like

Wow, thats a really handy app.
Seems that we are the only people using 5Ghz Wifi around me. So a lower channel is corresponding with a lower frequency, right? And lower frequency means a stronger signal further away from the router. So it should be at best when i use 5.18GHz at channel 36 compared to 5.5GHz at channel 100.

The most wifi networks at 2.4 GHz around here use channel 1-8. It appers we are alone at channel 12.

you could measure download rate too with the app.

Don’t forget 1000mW trans. power with channel > 100.
my experiences here is:
I provide a neigbour with MY WLAN ( 2 walls (Stahlbeton), ~10 m distance): best was channel > 100 with 5 GHz WLAN even 2.4 WLAN should do better on that distance (but I guess cause it’s so crowdy too)
channels < 100 was not seen by him !

choose channel 13 than. It’s more away from 8…

I tried to download the fedora workstation image (1.8GB), wget says 5.69 MB/s sounds good for me.