WiFi keeps disconnecting and reconnecting on a particular network

I have been getting this problem for a few days now when I was using fedora 35 it never happened only in the last few days before the update did it happen and continued in f36 too .

My WiFi never disconnects on other networks but when I use mobile hotstop this occurs also I think it happens after I have put my laptop to sleep . Can someone help me out . I also tried checking journalctl logs but could not make out much .

1 Like

My thought is that the hot spot is purposefully disconnecting you b/c it doesn’t want you to use data against your monthy cap when you’re not active.

Welcome to ask.:fedora:edora @emitsu

I do invite you to read this #start-here if you not done allready.
The information you gave us is very vague to give you a clear pointer in the right direction.

What i found with wifi problems and has a solution you can find here:

So could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.
to see how your specs are.

Side-note: I also had a wifi issue in #F36, but that was not really severe and could have been something different:

System:
  Kernel: 5.17.6-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.0
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Laptop System: Dell product: Inspiron 5559 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 04D1V1 v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.1.9 date: 03/01/2016
Battery:
  ID-1: BAT0 charge: 11.1 Wh (52.4%) condition: 21.2/41.4 Wh (51.2%)
    volts: 14.8 min: 14.8 model: Panasonic DELL 78V9D63 status: discharging
CPU:
  Info: dual core model: Intel Core i5-6200U bits: 64 type: MT MCP
    arch: Skylake rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 500 min/max: 400/2800 cores: 1: 500 2: 500 3: 500
    4: 500 bogomips: 19200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915
    v: kernel bus-ID: 00:02.0
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile]
    vendor: Dell driver: radeon v: kernel bus-ID: 01:00.0
  Device-3: Suyin Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:2
  Display: wayland server: X.Org v: 1.22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: i915 resolution: 1360x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 22.0.3
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.17.6-300.fc36.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: down mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-8:4
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 465.76 GiB used: 41.35 GiB (8.9%)
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB
Partition:
  ID-1: / size: 66.41 GiB used: 16.26 GiB (24.5%) fs: btrfs dev: /dev/sda1
Swap:
  ID-1: swap-1 type: zram size: 3.54 GiB used: 6.8 MiB (0.2%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 50.0 C pch: 41.5 C mobo: 38.0 C sodimm: SODIMM C
    gpu: radeon temp: 44.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 472 Uptime: 5m Memory: 3.54 GiB used: 2.25 GiB (63.8%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.1 Packages: 8
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.14

this is the output

i also checked on my phone and the security was set to WPA2-personal from the start .