Wifi not working on Mac Mini after installing Fedora

After installing Fedora 30, it doesn’t recognize any wifi devices so I can’t access my wireless router/Internet. Does anyone know how to fix this?

Update: installing the package “broadcom-wl” from RPMFusion’s non-free repository and rebooting allowed the wifi hardware to be recognized, but it gets an error when trying to connect to any network. The error is as follows:
wifi-error

Please share the result of these commands
lsusb
lspci

And also
sudo dmidecode |grep -A 9 "System Information"

Thanks

1 Like

Maybe it is this same issue?

@alciregi, thanks for your reply. Here’s the return of the commands:

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 013: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 007: ID 148f:5372 Ralink Technology, Corp. RT5372 Wireless Adapter
Bus 001 Device 005: ID 05ac:8242 Apple, Inc. Built-in IR Receiver
Bus 001 Device 010: ID 05ac:8289 Apple, Inc.
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
03:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM57766 Gigabit Ethernet PCIe (rev 01)
03:00.1 SD Host controller: Broadcom Inc. and subsidiaries BCM57765/57785 SDXC/MMC Card Reader (rev 01)
04:00.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
05:00.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
05:03.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
05:04.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
05:05.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
05:06.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
06:00.0 System peripheral: Intel Corporation DSL5520 Thunderbolt 2 NHI [Falcon Ridge 4C 2013]

suod dmidecode | grep -A 9 “System Information”
Wrong DMI structures length: 2717 bytes announced, only 2499 bytes available.
System Information
Manufacturer: Apple Inc.
Product Name: Macmini7,1
Version: 1.0
Serial Number: C07P37BFG1HW
UUID: 5f011521-6761-5a5d-8cdc-3d4451c4290d
Wake-up Type: Power Switch
SKU Number: System SKU#
Family: Mac

Invalid entry length (0). DMI table is broken! Stop.

The topic you referenced might be related. I’ll try their solutions and see if that fixes the issue.

After installing the broadcom-wl package from RPMfusion’s non-free repository and rebooting, Fedora now recognizes the internal WiFi card. However, attempting to connect to a wifi network produces this error: “Activation of network connection failed.”

wifi-error

Hi, there’s another workaround which is always solving the Broadcom WiFi connection problem for me.
Try to put:

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf

Have a look on that post:
https://bugs.archlinux.org/task/50541

2 Likes

That solved it. Thanks, @tsmarc!

1 Like

Does not work for BCM43142, just tried it, the result was a total loss of connection: even the wired connection failed because this solution kills NetworkManager. Had to remove

[quote=“tsmarc, post:6, topic:827”]
wifi.scan-rand-mac-address=no
[/quote] from /etc/NetworkManager/NetworkManager.conf, to get NetworkManager working again. At least the wired connection is restored now. Tried ALL solutions proposed on Ask Fedora: still no wireless connection on BCM 43142.
systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2019-05-24 08:06:32 CEST; 2min 7s ago
Docs: man:NetworkManager(8)
Process: 8041 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=1/FAILURE)
Main PID: 8041 (code=exited, status=1/FAILURE)

May 24 08:06:32 localhost.localdomain systemd[1]: NetworkManager.service: Service RestartSec=100ms expired, scheduling restart.
May 24 08:06:32 localhost.localdomain systemd[1]: NetworkManager.service: Scheduled restart job, restart counter is at 5.
May 24 08:06:32 localhost.localdomain systemd[1]: Stopped Network Manager.
May 24 08:06:32 localhost.localdomain systemd[1]: NetworkManager.service: Start request repeated too quickly.
May 24 08:06:32 localhost.localdomain systemd[1]: NetworkManager.service: Failed with result ‘exit-code’.
May 24 08:06:32 localhost.localdomain systemd[1]: Failed to start Network Manager.

@peterjmb, many Broadcom wireless chipsets want proprietary firmware to work and – as far as I know – other want proprietary driver too, both of which can’t be included in Fedora. I can’t say if your chipset is one of these, but it’s one of the things to look for when your Broadcom wireless doesn’t work in Linux.