Windows not shown in Grub (Windows and Fedora installed on separate SSDs)

I have the same problem and I tried these steps but the only benefit I got from it was accessing the GRUB menu again, but it still does not contain Windows option.

I tried to set the GRUB_ENABLE_BLSCFG value to false and repeat the mkconfig command, but it still doesn’t work.

Can you recommend something? By the way I have Windows and Fedora on separate SSD drives, I don’t know whether it matters or not.

1 Like

It does matter if each has its own efi partition.

1 Like

And how can I see my other SSD drive’s partitions from grub?

You can’t, but can only access it by the way grub sees it.

There are 2 ways to solve this (or actually 3)

The third is to use the bios boot menu and select which drive to boot. This will work right now without changes to grub.

The cleanest which avoids potential future issues is to combine the 2 efi partitions, fix the mount of /boot/efi so it reflects the efi partition you have merged to, then use mkconfig to update grub which will automatically use os-prober and locate windows to create the entry in grub for it to be added to the menu.

The next option is to edit /etc/grub.d/40-custom and create a menu entry there that will boot windows from its own location without altering the existing efi partitions.

My laptop, which dual boots from a single nvme drive, has the following entry in /boot/grub2/grub.cfg for booting windows.

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Boot Manager (on /dev/nvme0n1p1)' --class windows --class os $menuentry_id_option 'osprober-efi-42F8-BF3E' {
        insmod part_gpt
        insmod fat
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root  42F8-BF3E
        else
          search --no-floppy --fs-uuid --set=root 42F8-BF3E
        fi
        chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

I expect you could create a similar entry in /etc/grub.d/40_custom that would point to the proper drive and partition and boot windows from the grub menu after running grub2-mkconfig.
Note the search line before the chainloader line. I think that format is critical with the UUID used for the efi partition of choice.