Wine installation get "file conflict with dependencies" error

Trying to install wine on a RCA Cambio with Fedora 34. I am getting a lot of error’s “file conflicts with dependencies” and no install. can anybody help ?

2 Likes

Did you see that?

What kind of conflicts do you get ?

2 Likes

First, make sure your system is fully up to date.

If you are still getting errors, please post the exact commands you used and the exact errors so we can best help you. Thanks.

1 Like

OK , here it is. It’s large.

Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /usr/share/doc/expat/Changes from install of expat-2.4.1-1.fc34.i686 conflicts with file from package expat-2.2.10-2.fc34.x86_64
  file /usr/share/man/man1/xmlwf.1.gz from install of expat-2.4.1-1.fc34.i686 conflicts with file from package expat-2.2.10-2.fc34.x86_64
  file /usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.185-2.fc34.i686 conflicts with file from package elfutils-libelf-0.183-1.fc34.x86_64
  file /usr/share/locale/en@quot/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.185-2.fc34.i686 conflicts with file from package elfutils-libelf-0.183-1.fc34.x86_64
  file /usr/share/locale/pl/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.185-2.fc34.i686 conflicts with file from package elfutils-libelf-0.183-1.fc34.x86_64
  file /usr/share/doc/libxml2/README from install of libxml2-2.9.12-4.fc34.i686 conflicts with file from package libxml2-2.9.10-10.fc34.x86_64
  file /usr/share/doc/libxml2/TODO from install of libxml2-2.9.12-4.fc34.i686 conflicts with file from package libxml2-2.9.10-10.fc34.x86_64
  file /usr/share/doc/libidn2/NEWS from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/doc/libidn2/README.md from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/cs/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/de/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/eo/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/fr/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/hu/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/nl/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/pl/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/pt_BR/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/ro/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/sr/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/uk/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/locale/zh_CN/LC_MESSAGES/libidn2.mo from install of libidn2-2.3.2-1.fc34.i686 conflicts with file from package libidn2-2.3.0-5.fc34.x86_64
  file /usr/share/doc/nettle/NEWS from install of nettle-3.7.3-1.fc34.i686 conflicts with file from package nettle-3.7.2-1.fc34.x86_64
  file /usr/share/doc/libedit/ChangeLog from install of libedit-3.1-38.20210714cvs.fc34.i686 conflicts with file from package libedit-3.1-35.20210216cvs.fc34.x86_64
  file /usr/share/doc/gnutls/AUTHORS from install of gnutls-3.7.2-1.fc34.i686 conflicts with file from package gnutls-3.7.1-2.fc34.x86_64
  file /usr/share/doc/gnutls/NEWS from install of gnutls-3.7.2-1.fc34.i686 conflicts with file from package gnutls-3.7.1-2.fc34.x86_64
  file /usr/share/locale/ms/LC_MESSAGES/gnutls.mo from install of gnutls-3.7.2-1.fc34.i686 conflicts with file from package gnutls-3.7.1-2.fc34.x86_64
  file /usr/share/doc/gdk-pixbuf2/NEWS from install of gdk-pixbuf2-2.42.6-1.fc34.i686 conflicts with file from package gdk-pixbuf2-2.42.4-2.fc34.x86_64
  file /usr/share/locale/eu/LC_MESSAGES/gdk-pixbuf.mo from install of gdk-pixbuf2-2.42.6-1.fc34.i686 conflicts with file from package gdk-pixbuf2-2.42.4-2.fc34.x86_64
  file /usr/share/locale/nl/LC_MESSAGES/gdk-pixbuf.mo from install of gdk-pixbuf2-2.42.6-1.fc34.i686 conflicts with file from package gdk-pixbuf2-2.42.4-2.fc34.x86_64
  file /usr/share/man/man1/gdk-pixbuf-query-loaders.1.gz from install of gdk-pixbuf2-2.42.6-1.fc34.i686 conflicts with file from package gdk-pixbuf2-2.42.4-2.fc34.x86_64
  file /usr/share/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer from install of gdk-pixbuf2-2.42.6-1.fc34.i686 conflicts with file from package gdk-pixbuf2-2.42.4-2.fc34.x86_64
  file /usr/share/doc/libdrm/README.rst from install of libdrm-2.4.107-1.fc34.i686 conflicts with file from package libdrm-2.4.103-2.fc34.x86_64
  file /usr/share/libdrm/amdgpu.ids from install of libdrm-2.4.107-1.fc34.i686 conflicts with file from package libdrm-2.4.103-2.fc34.x86_64
  file /usr/share/doc/libpcap/CHANGES from install of libpcap-14:1.10.1-1.fc34.i686 conflicts with file from package libpcap-14:1.10.0-1.fc34.x86_64
  file /usr/share/doc/libpcap/README.md from install of libpcap-14:1.10.1-1.fc34.i686 conflicts with file from package libpcap-14:1.10.0-1.fc34.x86_64
  file /usr/share/man/man7/pcap-filter.7.gz from install of libpcap-14:1.10.1-1.fc34.i686 conflicts with file from package libpcap-14:1.10.0-1.fc34.x86_64
  file /usr/share/doc/libgcrypt/AUTHORS from install of libgcrypt-1.9.3-3.fc34.i686 conflicts with file from package libgcrypt-1.9.2-2.fc34.x86_64
  file /usr/share/doc/libgcrypt/NEWS from install of libgcrypt-1.9.3-3.fc34.i686 conflicts with file from package libgcrypt-1.9.2-2.fc34.x86_64
  file /usr/share/man/man5/ldap.conf.5.gz from install of openldap-2.4.57-5.fc34.i686 conflicts with file from package openldap-2.4.57-2.fc34.x86_64
  file /etc/fonts/fonts.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/doc/fontconfig/README from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/doc/fontconfig/fontconfig-user.html from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/doc/fontconfig/fontconfig-user.txt from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/09-autohint-if-no-hinting.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-autohint.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-hinting-full.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-hinting-medium.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-hinting-none.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-hinting-slight.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-no-sub-pixel.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-sub-pixel-bgr.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-sub-pixel-rgb.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-sub-pixel-vbgr.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-sub-pixel-vrgb.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/10-unhinted.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/11-lcdfilter-default.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/11-lcdfilter-legacy.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/fontconfig/conf.avail/11-lcdfilter-light.conf from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/licenses/fontconfig/COPYING from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64
  file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.13.94-2.fc34.i686 conflicts with file from package fontconfig-2.13.93-6.fc34.x86_64

It looks like I have a problem with my fonts?
I would sure appreciate any help.
Thank You

1 Like
# Sync to the latest package versions
sudo dnf distro-sync --refresh

# Find duplicates
sudo dnf repoquery --duplicates

# Remove duplicates
sudo dnf remove --duplicates
2 Likes

your problem is that you have both the .x86_64 and .i686 builds of a lot of packages installed.

2 Likes

I can see how that could be a problem. Do you have any suggestions on how to resolve it? I have not done much since I installed Fedora workstation 34, I did install Opera and thunderbird that’s about it other than trying to install WINE several times.
Thanks for the reply, Jim
ps, I will give Vladislav Grigoryev suggestion a try.

Thanks for the sug. Gave it a try,took awhile. Once that is done you sugessting I try a reinstall of WINE?

1 Like

Tthe issue here is Wine, which pulls in 32 bit libraries, but I don’t know any solution to that (last time I used Wine was probably 20 years ago). Not sure what happens to Wine if you remove the .i686 packages. Let’s see what Wine experienced users say…

I you have the possibility try to use a separate virtual machine installation and play around with wine there. If you mess up something everything else works as it should. Most time you need wine because of a few apps?

If you can visualize you not even depend on Fedora. You can use what focuses more windows … a distribution like Zorin etc.

Thank’s for the help , once I ran your suggestions I tried a reinstall of wine and it installed with out a problem.
Thanks again, Jim

1 Like