Xdmcp port 6000 is not listening

Fedora 33 beta

We use it for GUI installations like Oracle.

/etc/gdm/custom.conf

[security]
DisallowTCP=false

[xdmcp]
enable=true

Rebooted the machine.

# netstat -an|grep 6000

No listening port

1 Like
# Fix wrong case
sudo sed -i -e "/^enable=/s/^e/E/" /etc/gdm/custom.conf
sudo systemctl restart gdm.service

# Check ports
> sudo ss -l -n -p -A inet | grep -e gdm
udp   UNCONN 0      0            0.0.0.0:177       0.0.0.0:*    users:(("gdm",pid=5168,fd=12)) 

# Show SELinux port mappings
> sudo semanage port -l | grep -e xdmcp
xdmcp_port_t                   tcp      177
xdmcp_port_t                   udp      177

Wrong case is now fixed.

Rebooted

# more /etc/gdm/custom.conf
# GDM configuration storage

[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]
DisallowTCP=false

[xdmcp]
Enable=true

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true


# ss -l -n -p -A inet | grep -e gdm
udp   UNCONN 0      0            0.0.0.0:177        0.0.0.0:*    users:(("gdm",pid=877,fd=12))            
# semanage port -l | grep -e xdmcp
xdmcp_port_t                   tcp      177
xdmcp_port_t                   udp      177



# netstat -an|grep 6000
# 

Still the same issue. In Fedora 32, it is working fine. In Fedora 33 Beta, it’s not.

1 Like

If possible, use the default port that is 177/udp.
Firewall configuration by default:

sudo firewall-cmd --permanent --add-service=xdmcp
sudo firewall-cmd --reload

Otherwise, specify a custom port and make sure this is allowed by both SELinux and firewall.

Above didn’t work. I also disabled firewall and SELinux, rebooted the machine and it didn’t work either.

I issued ps -ef | grep -i xorg and I got the following:

Fedora 32:
/usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -listen tcp -background none -noreset -keeptty -verbose 3

Fedora 33 Beta (ran from Boxes of Fedora 32):
/usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset -keeptty -novtswitch -verbose 3

‘-listen tcp’ parameter is missing in Fedora 33 Beta while a new one ‘-novtswitch’ is being added.

1 Like

I tried this myself and have no problems on F33.

[root@localhost ~]# cat /etc/gdm/custom.conf 
# GDM configuration storage

[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]
DisallowTCP=false

[xdmcp]
Enable=true

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

And I also do not see ‘listen tcp’.

/usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset -keeptty -novtswitch -verbose 3

 # netstat -tulpen  | grep dm
 udp        0      0 0.0.0.0:177             0.0.0.0:*                           0          29328      811/gdm
1 Like

We need Fedora 33 Beta (as a client) to be listening on port 6000 in order to remotely run X commands like ‘runInstaller’, ‘netmgr’, ‘dbca’, etc… commands of Oracle server running On Oracle SPARC Solaris.

In Fedora 32, the output of ‘netstat -an’ is showing:

$ netstat -an | grep 6000
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp6 0 0 :::6000 :::* LISTEN

In Fedora 33 Beta, there is no port 6000 listening after modification of /etc/gdm/custom.conf file and reboot.

Looks like you do not need xdmcp. Are you running wayland or X on Fedora 33 beta? In case of wayland I can imagine nothing is listening in the 6000 port range.
How do you connect to solaris? With ssh, telnet or xdmcp chooser?

I am running Xorg. I am selecting it when I login.

I am now on Fedora 33. Still same problem. No port 6000 listening.

On my Fedora workstation, I am doing the following:

fedora33 xhost + fedora33 ssh oracle@solaris
.
solaris export DISPLAY=IP:0.0 solaris cd /oracle/database
solaris $ ./runInstaller

Running Xorg is good.
Why don’t you use ssh’s x-forwarding?

ssh -X oracle@solaris
./runInstaller

If x-forwarding is not working, did you open port 6000-6010 on the firewall on fedora?

I disabled the firewall completely:

systemctl status firewalld.service

● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:firewalld(1)

more /etc/gdm/custom.conf

GDM configuration storage

[daemon]

Uncomment the line below to force the login screen to use Xorg

#WaylandEnable=false

[security]
DisallowTCP=false

[xdmcp]
Enable=true

[chooser]

[debug]

Uncomment the line below to turn on debugging

#Enable=true

netstat -an|grep 6000

The problem is that there is no port 6000 listening after configuration. I am of course using GNOME on Xorg upon logging in.

Here is what I found on RedHat support portal:

Bug 1658464 - Xorg listening on port 6000 by default in 7.6 [rhel-7.6.z]

I don’t know how much this relates to my case, but as I am struggling to let Xorg listen on port 6000, it seems that it is a security vulnerability to have port 6000 open…?

Kindly Advise.

What is the output of ps -ef | egrep "dm|X" ?
Why don’t you use ssh’s x-forwarding?

ps -ef | egrep "dm|X" root 147 2 0 17:56 ? 00:00:00 [dm_bufio_cache] earlyoom 648 1 0 17:56 ? 00:00:00 /usr/bin/earlyoom -r 0 -m 4 -M 409600 --prefer ^Web Content --avoid ^(dnf|packagekitd|gnome-shell|gnome-session-c|gnome-session-b|lightdm|sddm|sddm-helper|gdm|gdm-wayland-ses|gdm-session-wor|gdm-x-session|Xorg|Xwayland|systemd|systemd-logind|dbus-daemon|dbus-broker|cinnamon|cinnamon-sessio|kwin_x11|kwin_wayland|plasmashell|ksmserver|plasma_session|startplasma-way|xfce4-session|mate-session|marco|lxqt-session|openbox)$
root 804 1 0 17:56 ? 00:00:00 /usr/sbin/gdm
root 1422 804 0 17:56 ? 00:00:00 gdm-session-worker [pam/gdm-password]
user1 1457 1422 0 17:57 tty2 00:00:00 /usr/libexec/gdm-x-session --run-script --allow-remote-connections /usr/bin/gnome-session
user1 1460 1457 1 17:57 tty2 00:00:02 /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset -keeptty -novtswitch -verbose 3
user1 2693 2293 0 17:59 pts/0 00:00:00 grep -E --color=auto dm|X

I will try ssh x-forwarding. Doesn’t it need port 6000 to be listening?

For x-forwarding nothing needs to listen on port 6000. Make sure xauth is installed on solaris. If you search for “xauth solaris” on the internet you will find lots of information regarding your issue.

1 Like

Hello,

I reverted /etc/gdm/custom.conf to default. No parameters were added.

OS rebooted.

I used ssh -X oracle@sparcsrv and my problem is now solved with X11 and Wayland.

Thank you so much.

1 Like