Xorg-x11-drv-nouveau

The backtrace does not contain enough meaningful function frames to be reported. It is annoying but it does not necessarily signalize a problem with your computer. ABRT will not allow you to create a report in a bug tracking system but you can contact kernel maintainers via e-mail.

**Can anyone help me solve this problem I am unable to solve this error…? and I don’t know what this is…Please can you explain what this error is about…?

It seems that there are some issues related to the Nouveau driver. More verbose errors can be gathered with something like:

sudo journalctl -b -e

Which will show all of the system logs from the last boot. Then you can page-up or something until you stumble upon the error that you noted in screenshot.

Anyhow, could you try to locate relevant logs in journal and attach them?

Slightly offtopic, I saw your other post on using Nvidia driver, so am wondering, how have you installed those drivers? This error happens after the Nvidia driver install?

2 Likes
`how have you installed those drivers`

I have created a topic on that recently and someone gave me this link
https://docs.fedoraproject.org/en-US/quick-docs/how-to-set-nvidia-as-primary-gpu-on-optimus-based-laptops/
and through I installed the drivers…

No a lot crash reports used to pop on on the notification bars…

Asking because it would seem nouveau (open version of Nvidia driver) is still trying to start up. To be completely honest, I am not using hybrid graphics so I might be giving you wrong information. Perhaps someone with more experience can chime in.

That being said. From what I vaguely remember, nouveau driver should be blacklisted and then the issue would not happen. I only have dedicated Nvidia graphics card, not that hybrid setup, but the mere driver installation creates blacklist option for nouveau for me automatically.

For the verification sake, you’re getting desired result as the output of the following command?

glxinfo | grep -E "OpenGL vendor|OpenGL renderer"

Also, you followed instructions to the letter? Including the akmod/dracut image generation and waiting for modules to be compiled beforehand?

I think I don’t have glxinfo… How can i install it…should I have to do

sudo dnf install glxinfo

for installing that …

@masteroman can you tell me how to get to know with these glxinfo, grep and others commands ?

Command glxinfo is a part of the glx-utils. I believe it should be provided by default.

Just open up terminal and try running it there. Alternatively, if you’re missing glxinfo command, then you might need to install it with:

sudo dnf install glx-utils

If you get Nvidia in both outputs, driver should be successfully installed, which means nouveau can be blacklisted as a kernel parameter.

Have you followed guide you’ve linked originally to the letter or have you omitted some steps?

1 Like

seems like fedora has it by default…

Last metadata expiration check: 0:56:15 ago on Wed 10 Mar 2021 05:36:21 AM +0545.
Package glx-utils-8.4.0-8.20181118git1830dcb.fc33.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

But while I do

glxinfo | grep -E “OpenGL vendor|OpenGL renderer”

It returns

Usage: grep [OPTION]… PATTERNS [FILE]…
Try ‘grep --help’ for more information.

The double quotes used in that command are from windows, not linux. Replace them.

Are you by chance using a windows terminal with putty to connect to the linux machine? If so some things may not be the same as from a linux terminal. If not then the desktop font you are using is not linux compatible with all symbols such as the double quote you just posted.

Also, tell us what shell you are using. Use the command “echo $SHELL” to find out.

Is there such thing as linux compatible fonts?


and I don’t know what the above commands does…
So can anyone explain what does that command mean…??

/bin/bash

Of course, almost all linux distros use them by default.
The incompatibility usually comes from using a windows font on a linux command line, or from changing the default font in the terminal to something else.

Note the difference between what you posted above (first line) and what it looks like with the double quotes from my system (second line)

lxinfo | grep -E “OpenGL vendor|OpenGL renderer”
lxinfo | grep -E "OpenGL vendor|OpenGL renderer"
1 Like