Zoom Client Audio Share Requires PulseAudio

I’m running F34 and the official Zoom client claims it needs pulseaudio to share audio, but I have no interest in replacing pipewire with pulseaudio.

Is this just a situation where I need to wait until Zoom unveils pipewire support or is there a work-around I don’t know about?

Thanks for any insight, suggestions, and support…

2 Likes

As i know there is a pulsaudio plugin while using pipewire. At least I use Zoom client from zoom.us without troubles on F34.

4 Likes

Is this your case here?
Audio may not work after upgrade to Fedora 34 if pipewire was previously installed

3 Likes

+1, this should be enough.

@bryanmoore can you please check what pipewire packages you have installed on your system? These are what I have, and zoom works fine:

$ rpm -qa \*pipewire\*
pipewire0.2-libs-0.2.7-5.fc34.x86_64
pipewire-0.3.26-4.fc34.x86_64
pipewire-libs-0.3.26-4.fc34.x86_64
pipewire-gstreamer-0.3.26-4.fc34.x86_64
pipewire-alsa-0.3.26-4.fc34.x86_64
pipewire-jack-audio-connection-kit-0.3.26-4.fc34.x86_64
pipewire-pulseaudio-0.3.26-4.fc34.x86_64
pipewire-utils-0.3.26-4.fc34.x86_64
2 Likes

Thanks @ilikelinux & @ankursinha for the suggestions; I’ll check on this when I can access the machine later and circle back.

2 Likes

3 posts were split to a new topic: Zoom crashes on F34

@ankursinha, not much difference:

[bryan@fedora ~]$ rpm -qa \*pipewire\*
pipewire0.2-libs-0.2.7-5.fc34.x86_64
pipewire-libs-0.3.26-4.fc34.x86_64
pipewire-0.3.26-4.fc34.x86_64
pipewire-alsa-0.3.26-4.fc34.x86_64
pipewire-gstreamer-0.3.26-4.fc34.x86_64
pipewire-jack-audio-connection-kit-0.3.26-4.fc34.x86_64
pipewire-pulseaudio-0.3.26-4.fc34.x86_64
pipewire-utils-0.3.26-4.fc34.x86_64
2 Likes

That’s very odd then. I’ve not had any issues here. :thinking:

What version of zoom are you using, and how have you installed it?

$ rpm -q zoom
zoom-5.1.422789.0705-1.x86_64

Could you create a new user to see if the issue persists? That’ll tell us if it’s perhaps some config for your particular user that’s causing it.

1 Like

zoom-5.6.16888.0424-1.x86_64

Issue persists with new user. Perhaps it’s the pipewire-jack-audio-connection-kit-0.3.26-4.fc34.x86_64 package, although I don’t know why it would be…

What is the actual issue? Is it that it complains about the lack of pulse audio or that it doesn’t work.
My installation gives a message:
No PulseAudio daemon running, or not running as session daemon.
but the audio works.

No audio, for me…

To Ankur Sinha you gave feedback. I’m not sure if you really checked my link too? Please following the important text on the bottom to check.
As i remember we installed Pipewire while using F33 in a other Topic right. So i could imagine that you have maybe not copied away your config file before reinstalling alias updgrading.

Audio may not work after upgrade to Fedora 34 if pipewire was previously installed

link to this item - Bugzilla: #1931384

Some users have reported that pipewire (the default audio framework in Fedora 34) may not work properly on update from older versions due to a configuration file format incompatibility. If you had pipewire installed in Fedora 32 or 33, it may stop working on upgrade to Fedora 34. If this happens to you, we recommend moving all *.conf files out of /etc/pipewire and reinstalling pipewire with sudo dnf reinstall pipewire pipewire-pulseaudio . You will then need to re-apply any customizations you had made to the configuration files.

1 Like

Sorry @ilikelinux, I meant to respond to you, too. This is a clean install, no upgrade from 33; although, I had installed the 34 beta. Do you think that could be the root of the issue?

2 Likes

Yes, so you have same situation as me, i had some issues with sound and could solve them this way. It is a incompatibility with the config files. Copy them away to have a backup if you had a special setting.

2 Likes

Still doesn’t work for me…
Screenshot-20210508135222-558x219

1 Like

PuluseAudio ? :scream_cat:

2 Likes

Right?

I’ve contacted Zoom support to see if they have any ideas because I’m out of them.

2 Likes

Okay, on a whim I removed the official Zoom package (from them) and installed the flatpak via Software. Upon initial launch it complained that “screen sharing” wasn’t enabled for Wayland, but after a quick app restart, boom, audio share works flawlessly.

This isn’t a fix, as the issue with the official package persists, though.

2 Likes

Yes odd… I’m using X rather than Wayland, so that may explain the different experience.

1 Like

One of my suspicions was it could be either Wayland or some selinux issue, since I had plenty of those with any openvpn setting not from cli.

1 Like